Deploy Comodo ModSecurity Rule Set in cPanel

Comodo ModSecurity protection rules are now integrated into cPanel/WHM and can be activated from the 'Security Center'.

  • Sign in to your cPanel/WHM (root) account

    Important Note: cPanel ModSecurity Vendors are not compatible with the CWAF plugin. So, you can't use both in parallel for the management of your protection rules.

    Don't activate both Comodo Rule Sets for Apache and LiteSpeed simultaneously to avoid conflicts.

  • Click the 'Security Center' tab from the left menu, then 'ModSecurity Vendors'
  • Click 'Add Vendor' in the 'ModSecurity Vendor Manager' screen.

In the 'Add Vendor' page, enter the vendor configuration URL depending on your webserver type.

  • Enter the appropriate URL in the 'Vendor Configuration URL' field and click 'Load'

    The vendor details will be fetched and automatically filled in the fields.

  • Click the 'Save' button.

  • That's it. Comodo ModSecurity Rules Set is now activated in cPanel.
  • 1 Users Found This Useful
Was this answer helpful?

Related Articles

How to fix defaultwebpage.cgi on a webserver

Running the following commands solves the above problem:   /scripts/updateuserdomains...

How to fix IP Missing issue on cPanel/WHM

We are here to help you with solving the problem of Missing IP Server in list accounts. The...

Install Let's Encrypt SSL in cPanel/WHM

Let's Encrypt, a valid, open-source license that offers free SSL for your domains. The Let's...

Fix Email Issue on a server using the MSFE

To solve the problem of not sending/receiving email on a server using the MSFE / Mailscanner...

Domain names are not showing in WHM

We were unable to see any domains listed under WHM -> List Accounts. However, we can see the...