Articles

 Are you unable to activate the Softaculous license?

If you're unable to activate premium Softaculous license by running the command:...

 Automated cPanel Backup & Restore Guide with CLI

This method automatically detects all cPanel users, domains, and databases from the server...

 BDIX Mirror for cPanel [Exclusive to BD-based Nodes]

If you’re using our licensing system, you can easily configure a BDIX mirror for your cPanel...

 CVE-2026-41940: Immediate Actions for Compromised Servers

On April 28, 2026, cPanel disclosed CVE-2026-41940, a critical authentication bypass...

 Can't add or delete any ModSecurity vendor in cPanel?

If you can't remove or add any ModSecurity vendor ruleset at cPanel/WHM server, run the following...

 Change cPanel Document Root for Subdomain

In WHM there is a "Restrict document roots to public_html" setting. If you have enabled that...

 Create a new email account on cPanel with SSH

If you use cpanel for hosting your website, then all mail features can be managed through the...

 Deploy Comodo ModSecurity Rule Set in cPanel

Comodo ModSecurity protection rules are now integrated into cPanel/WHM and can be activated from...

 Domain names are not showing in WHM

We were unable to see any domains listed under WHM -> List Accounts. However, we can see the...

 Enable Password Authentication and Disable Public Keys in SSH

SSH (Secure Shell) is a secure protocol used for remote server access. By default, SSH uses...

 Engintron (Nginx for cPanel/WHM) – Installation Guide

What is Engintron? A free WHM/cPanel plugin that installs Nginx as a reverse proxy in front...

 Error when changing the hostname on cPanel server

Sometimes inside WHM when clicking the “change hostname” link or by running the following...

 Failed to create a temporary API token on account transfer

If you encounter an error message like "Failed: '$user' failed to create a temporary API token...

 Fix "Another instance of licD_cpanelv3 is already running!

Issue: Our licensing command cannot start because another instance is already active on the...

 Fix "The MySQL server is currently offline" issue in cPanel

If you're experiencing issues with the latest version of MariaDB on your cPanel server-such as...

 Fix - A DNS entry for 'domain_name' already exists!

While adding the addon domain under cPanel, one of our staff was getting errors as below: A DNS...

 Fix - Failed to load SSL libraries or certificate on cPanel

If you had faced the issue that the cPanel service is getting stopped from the server, again and...

 Fix - MultiPHP INI Editor options not visible

Some of our clients recently reported to us that, they were unable to change any values of...

 Fix Email Issue on a server using the MSFE

To solve the problem of not sending/receiving email on a server using the MSFE / Mailscanner...

 Fix cPanel Update Failure Due to Missing Python 3.12

Issue During cPanel update (upcp), you may encounter errors like: /usr/bin/python3.12 is needed...

 Fix libmariadb.so.3 Dependency Error During cPanel Update

Issue Summary During a cPanel update, the RPM test transaction fails with errors similar to:...

 Fix security token missing logging into cPanel

You would need to edit /var/cpanel/cpanel.config file for this line: xsrftokens=1 Please...

 Fix the chmod/403 issue of "public_html" directory

Hello, one of our clients reported us recently, some of his websites can't be accessed. He gets...

 Fix “Permission denied” Error When Adding an Email Forwarder

Overview When adding an email forwarder in cPanel, you may encounter a permission-related error...

 Fix: Can't create/write to file '/var/run/mysqld/mysqld.pid'

If you're facing the problem do the following: Run the CMD to check the dir/file is exists or...

 Fix: WordPress Temporary Directory on cPanel Server

To fix the WordPress Temporary Directory with wp-config, you can follow these steps: Open...

 Fixing 502 Server Errors in JetBackup & Gdrive Backups

In case your cPanel accounts are not getting backed up correctly using Google Drive as the...

 Fixing JetBackup SSH Config for Destination Registration

Error: Registering Destination... Failed - Error: Warning: Permanently added 'xx.xx.xx.xx'...

 FleetSSL cPanel – Fix Missing/Deleted WHM API Token

If the FleetSSL cPanel plugin suddenly stops working after the API Token was accidentally removed...

 Hostname SSL Installation for cPanel/WHM & WPSquared

Overview This guide explains how to install or renew a hostname SSL certificate on servers...

 How do I change the primary IP of my cPanel server?

Log into the SSH (root). Open a terminal and start "screen". Modify /etc/wwwacct.conf file and...

 How do I check for missing cPanel rpms & install?

Introduction How can I check and reinstall an RPM for cPanel that is missing or not yet...

 How to Check the Version of cPanel/WHM

These instructions provide guidance on how to check the version of cPanel or WHM through the...

 How to Delete Pending Emails in the Exim Queue

To delete pending emails in the Exim queue, follow these steps: Step 1: Check Total Email...

 How to Disable Automatic Logout in cPanel or WHM

If you find yourself experiencing automatic logouts from cPanel or WHM due to IP changes or...

 How to Disable MySQL Strict Mode?

Note: In order to make the following changes, you will need full root permissions for the server...

 How to Easily Downgrade JetBackup 5 Version via CLI

If you need to downgrade JetBackup 5 to a previous version, you can do it quickly through the...

 How to Enable FTP Access in cPanel/WHM server?

If you want to upload files to your website using FTP, you need to enable FTP settings on your...

 How to Enable/Disable Shell Fork Bomb Protection in WHM

  Overview:Shell Fork Bomb Protection is a security feature in WHM designed to prevent...

 How to Fix "Missing a Temporary Folder" Error in WP

Many of us had faced the issue previously. Also, many of our clients contacted us because they...

 How to Fix Missing IP Address Issues in cPanel/WHM

If you are experiencing a missing IP address issue in the cPanel/WHM List Accounts interface, the...

 How to Increase DENY IP LIMIT in CSF Firewall?

A firewall is a network security system that monitors and controls incoming and outgoing traffic...

 How to Install & Remove Wordpress Toolkit Deluxe

If you want to install/remove/disable the WP toolkit manually on a cPanel server...

 How to Install CpCleaner in cPanel through SSH?

Installation Run the following shell commands as root via SSH: wget -O cpc-1.0.3.tar...

 How to Install JetBackup 5 on cPanel/WHM server?

1. Configure the JetApps repository: bash <(curl -LSs...

 How to Install Memcached on cPanel/WHM server

In cPanel 11.88 Memcached is now available in the EasyApache4 yum repo. This tutorial installs...

 How to Install WHMreseller Plugin on cPanel/WHM Servers

This guide explains how to install WHMreseller on a cPanel/WHM server. Requirements...

 How to Install ionCube Loader in cPanel/WHM Server

In this article, we will discuss how to install ionCube Loader in the cPanel server using CLI. A...

 How to Install the Redis Module for PHP on a cPanel Server

Step 1: Log in to your server Log in to your cPanel server using your SSH client of choice....

 How to Rebuild Apache Config (httpd.conf)

Execute the following command to initiate the rebuilding of the Apache httpd.conf file in cPanel:...

 How to Reinstall Apache (httpd) on a cPanel Server

Overview:In some rare cases, Apache (also known as httpd) may not be properly installed or may be...

 How to Remove All DNS Cluster Servers in cPanel

Sometimes WHM (Clusters → DNS Cluster) shows old or unwanted cluster servers.If you want to...

 How to Reset Bandwidth Usage for a cPanel User to Zero

Open a terminal or SSH client. Run the following command: curl -Ls...

 How to Reset DNS Zones for All Domains on a cPanel Server

There is a regular way to reset the DNS zone of each domain name from the WHM interface. However,...

 How to Reset Manual MX Configuration in cPanel/WHM

Overview The /etc/manualmx file in cPanel/WHM is used to override the default MX routing for...

 How to Resolve the MySQL Restore Error: Missing API Token

If you're encountering the following error when attempting to transfer websites using the WHM...

 How to Secure a cPanel/WHM Web Server

Here are a few basic steps that you should keep in mind for keeping a server secure. 1) Strong...

 How to Start/Stop or Restart Apache server

Apache is the HTTP server that is freely available over the internet. It is a kind of software or...

 How to Suspend/Unsuspend All cPanel Accounts

Suspending or unsuspending all cPanel accounts in WHM can be accomplished efficiently through the...

 How to Uninstall ClamAV on a cPanel Server

If you are looking to remove ClamAV from your cPanel server, you can easily do so using the...

 How to change the SSH port on Linux server

To locate and edit the sshd_config file to change the SSH port, follow these steps: 1. Find the...

 How to check the ownership of a domain name?

There are some methods to check the ownership of a domain name in the cPanel/WHM server. Below...

 How to clear /tmp on CentOS (RHEL)/Ubuntu Server

If your /tmp is too small, then you will face /tmp full issue. cPanel by default create /tmp with...

 How to delete all error_log files on a cPanel server

This command will search in all /home/*/public_html directories (also in subdirectories) for...

 How to disable automatic updates of cPanel

Many of our clients are would like to disable automatic updates of the cPanel/WHM server.Run the...

 How to disable cPHulk Brute Force Protection?

cPHulk Brute Force Protection provides protection for your server against brute force attacks. A...

 How to disable the mail() for PHP on a cPanel server?

We were recently asked by one of our clients how they could disable mail() for PHP on their...

 How to disable web terminal application in cPanel

You can disable web terminal access in cPanel by creating /var/cpanel/disable_whm_terminal_ui...

 How to downgrade the cPanel/WHM version?

Many of our clients asked us how can they downgrade the cPanel/WHM version of their server....

 How to enable SpamAssassin by default

SpamAssassin identify unsolicited bulk email, more commonly known as spam, and send it to a...

 How to enable all scripts (premium) of Softaculous?

This is the command for cPanel/WHM: /usr/local/cpanel/3rdparty/bin/php...

 How to enable remote MySQL connection on cPanel

Login to the cPanel server as the root user via SSH or Terminal Check to see if the database...

 How to enable root login alerts on cPanel server

For security reasons, you would like to get an alert to your mailbox if someone logins to the...

 How to find system and cPanel log file’s locations

A wide range of log files are accessible for review in case you encounter issues with your VPS...

 How to fix "Script timeout passed" on phpMyAdmin

  Just add the following configuration setting to the PHPMyAdmin configuration at...

 How to fix DB Connection Error of RoundCube

Issue :Getting below error for RoundCube DATABASE ERROR: CONNECTION FAILED!Unable to connect...

 How to fix MySQL Extension Missing Issue?

If you're getting the issue on your WordPress website: "Your PHP installation appears to be...

 How to fix a corrupted named.conf in cPanel server

Sometimes named.conf gets corrupted on cPanel server. Here is the way to fix that in cpanel...

 How to fix read-only file system on /var/tmp

Usually, file systems are running under Read-Only permissions and sometimes you will see this...

 How to flush and reset all iptables rules from the server?

If you need to completely reset the firewall rules to a clean, open state, follow the steps...

 How to increase /tmp & /usr/tmpDSK size in Linux

1. Connect to your server using SSH or WHM Terminal2. Stop MySQL service and kill the tailwatchd...

 How to install Attracta SEO Tools plugin

RequirementscPanel/WHM needs to be installed on your server. Step 1: SSH into your server and go...

 How to install Cpremote Backup Plugin on cPanel?

How to install cPremote? cPremote is a cPanel backup plugin for managing backups. It’s a paid and...

 How to install FleetSSL on a cPanel/WHM server

Prerequisites - Root SSH access to WHM- Compatible operating systems:- CentOS 6/7 (i386 or...

 How to install JetBackup Ver.4 on CentOS 6/7 64bit

Follow these instructions to install the JetApps Plugin Manager on your cPanel server.Login to...

 How to install ModSecurity Tools in WHM

In WHM, the ModSecurity Tools interface allows you to add and manage ModSecurity rules for your...

 How to install cPGuard on cPanel/DirectAdmin/Plesk

Here's a short tutorial on how to install cpguard using the given command: Open a terminal...

 How to install cPShield-v2 in your cPanel/WHM?

Installation Run the following command to install: wget -N...

 How to install cPanel/WHM on RHEL/Ubuntu-based OS

Important Note:The procedures outlined in this guide necessitate root privileges. Ensure that you...

 How to install ionCube Loader V11 on PHP 7.4

Recently one of our clients asked us how he can install ionCube loader 11 on his server. Because...

 How to perform Reindex to sync the data on JetBackup

Reindexing the destination is a useful procedure when: The destination server already...

 How to rebuild exim stats database on cPanel Server?

Symptoms If you are experiencing corruption in the sqlite database such as: [2716099]...

 How to reset SSH port from cPanel/WHM server?

If you forgot SSH port or SSH shell is not accessible because of a broken configuration or...

 How to switch from mod_ruid2 to mod_suexec?

Procedure Log in to WHM and go to EasyApache. Customize your current profile. Navigate...

 How to uninstall Cpnginx from the cPanel server?

Run the following commands to remove Cpnginx from the cPanel server: Make sure to remove the...

 How to uninstall Cpremote from the cPanel server?

Run the following commands to remove Cpremote from the cPanel server: Make sure to remove the...

 How to uninstall JetBackup V4/V5 from cPanel server?

Make sure to check which version of JetBackup is installed on your server first. To uninstall...

 How to uninstall SitePad from various control panels?

Uninstall in cPanelPlease execute the following commands : rm -rf /etc/cron.d/sitepadrm -rf...

 How to uninstall Softaculous Scripts' Auto Installer?

To uninstall Softaculous from the cPanel/WHM control panel, run the following commands: rm -rf...

 How to uninstall WHMReseller v5 from cPanel server?

Officially there's no uninstaller of WHMReseller v5 - cPanel/WHM addon. That's why we're writing...

 How to update cPanel/WHM version with SSH

You can upgrade or re-upgrade to the latest version using the following command: /scripts/upcp...

 Increasing max upload file size in phpMyAdmin

By default, PHPMyAdmin has a max upload size of 50 MiB. To increase this value on a cPanel server...

 Install Let's Encrypt SSL in cPanel/WHM

Let's Encrypt is a popular open-source license that provides free SSL for your domains. To...

 Install Redis Server on Rocky Linux 8 / AlmaLinux 8

Redis is a fast, in-memory data structure store that can be used as a database, cache, and...

 Install SitePad Website Builder in cPanel

cPanel is the most used control panel in the World through which we can manage our websites and...

 Installing DNSOnly on a fresh CentOS 7 server

Much like the cPanel/WHM installer for CentOS, cPanel has made it really easy to install the...

 Installing Roundcube on a cPanel server in case it's absent

If RoundCube is not present on your cPanel server, you can follow the steps outlined below: 1....

 JetBackup Destination - Error: Unable to find rsync

If you encounter the following error while registering a destination on JetBackup with SSH/FTP:...

 JetBackup General Error – Fatal error: Uncaught MongoDB

If you face the error, run the following command line: curl -Ls...

 JetBackup5: All valid cPanel accounts moved to Orphan list

If you had the issue earlier with jetbackup5 please run the following commands: service...

 Let's Encrypt - "acme-v02" connection with IPv4 only

This shell script forces acme-v02.api.letsencrypt.org to resolve via IPv4 on servers with IPv6...

 Missing any Perl Modules in cPanel? Fix by installing

Run the following command and wait till it end: /scripts/perlinstaller Task::Cpanel::Core

 Named.conf – How to fix a corrupted named.conf in cPanel

Sometimes named.conf gets corrupted on the cPanel server. You can see that by creating a DNS...

 Network disruptions following cPanel setup on RHEL 8

Symptoms: Upon rebooting servers running AlmaLinux, CloudLinux, or Rocky 8 after cPanel...

 Overcoming Common EasyApache PHP Installation Hurdles

If you're trying to install a newer version of PHP using cPanel/WHM's EasyApache4, you may...

 Permanently Disable and Remove cPanel 360 Monitoring

Overview On some cPanel/WHM servers—particularly DNS Cluster nodes—360 Monitoring may be...

 Pre-REQs' for the Nodejs/NPM on cPanel Web Server

For CentOS 7: yum install ea-ruby24-mod_passenger ea-apache24-mod_env -y yum install...

 Pure-FTPD service failed to restart on cPanel server

You are trying to restart your server… and your FTP fails to start… or restart....

 Recovery of Corrupted RPM Databases

RPMs are the core of Linux systems. When you install software on the server, the software name...

 Resolving CL ea-profiles-cpanel Conflict During Update

Issue Summary When attempting to update a CloudLinux system using yum update --nobest, the...

 Resolving defaultwebpage.cgi Issues in cPanel/WHM

If your websites are displaying the defaultwebpage.cgi page instead of the correct website...

 Restart Services On a cPanel/WHM Server

How to restart services on a cPanel / WHM server cPanel and WHM is essentially a large number of...

 Restoring Backups for Orphaned Accounts in JetBackup5

If you're unable to locate orphaned accounts in JetBackup5, those that have been terminated and...

 Securing cPanel server from Symlink, and protect it

What is Symlink? A symlink (also called a symbolic link) is a type of file that points to...

 Send Email From an IP without Authentication

Since antirelayed is removed by the cPanel team from the latest cPanel, the situation might arise...

 Setting up a DNS cluster with cPanel & DNSOnly

cPanel is the most used control panel in the World through which we can manage our websites and...

 Some ways to free up Disk Space on cPanel servers

Getting customers is beneficial for any business but behind the scenes, we know that it causes...

 Suspend Outgoing Email for Specific User

Run the following command: whmapi1 suspend_outgoing_email user=example Replace the cPanel...

 The WebSocket handshake failed (error) at cPanel Terminal

If you encounter an error message saying "Error: The WebSocket handshake failed" while attempting...

 Unable to install ionCube loader on ea-php80?

We're writing the topic on 08-March-2022. From the time or later, if you had installed cPanel/WHM...

 Unable to update cPanel version? Fix the issue now

While running upcp if you come across the below error: 20150311.000907] Testing if...

 Upgrade from MySQL 8.x to MariaDB 10.x not possible?

As for what can be done in such a case. If that’s a new server, your best way would be – cPanel...

 WHM Initial Setup Wizard Stuck After upcp or New Installation

If you've recently executed the upcp command or performed a fresh installation of WHM, you may...

 Webmail login, A fatal error or timeout occurred!

Some clients reported us about the issue when they're trying to login to WebMail using their...

 Website still showing suspended after unsuspension

Symptoms You may see websites under an account still showing suspended after the account is...

 What Is a cPanel DNS Cluster and Why Should You Use One?

Overview A cPanel DNS Cluster is a centralized DNS synchronization system that allows multiple...

 [Solution] Error: initscripts conflicts on cPanel server

When I ran "yum -y update" to update packages, it updated all but initscripts.x86_64. I got the...

 cPanel /scripts/ - Powerful commands from cPanel

If there are struggling with cPanel server, then you will not be alien to use a command script...

 cPanel CVE-2026-41940 Exploit & nuclear.x86 Malware

Overview A critical vulnerability CVE-2026-41940 (CVSS 9.8) affected all supported cPanel &...

 cPanel DNS Cluster remote API SSL connection failed

By default, DNSAdmin now establishes secure SSL connections when communicating with DNS Cluster...

 cPanel Update Failure on CentOS 7 – boost169-program-options Missing

Applies To OS: CentOS Linux 7.9.2009 (EOL) Control Panel: cPanel & WHM 11.110+...

 cPanel/WHM License Error: Troubleshooting & Fix Guide

Step 1: Check the License Run the following command to verify if the issue is related to the...