Pure-FTPD service failed to restart on cPanel server

You are trying to restart your server… and your FTP fails to start… or restart.

/scripts/restartsrv_pureftpd
Waiting for “pureftpd” to restart ………warn [restartsrv_base] The 'pureftpd' service's PID file '/var/run/pure-ftpd.pid' did not appear after 10 sec.

…warn [restartsrv_base] The 'pureftpd' service's PID file '/var/run/pure-ftpd.pid' did not appear after 10 seconds.

    Service Error The “pureftpd” service failed to start.
    Startup Log
    Starting pure-config.pl: [  OK  ]
    Starting pure-authd:

pureftpd has failed. Contact your system administrator if the service does not automagically recover.

The reason for this error is that Pure-FTPD service doesn’t work with {CallUploadScript} set to (yes) in /etc/pure-ftpd.conf configuration file. That is because the pure-uploadscript service is not getting started while restarting the pure-ftpd service.

Run the following command via SSH to fix this issue:

/usr/sbin/pure-uploadscript -B -r /etc/pure-ftpd.conf

Restart the service :

/scripts/setupftpserver pure-ftpd -force

And your service will restart successfully.

  • 4 Users Found This Useful
Was this answer helpful?

Related Articles

Domain names are not showing in WHM

We were unable to see any domains listed under WHM -> List Accounts. However, we can see the...

How to Start/Stop or Restart Apache server

Apache is the HTTP server that is freely available over the internet. It is a kind of software or...

How to install Attracta SEO Tools plugin

RequirementscPanel/WHM needs to be installed on your server. Step 1: SSH into your server and go...

How to Install CpCleaner in cPanel through SSH?

Installation Run the following shell commands as root via SSH: wget -O cpc-1.0.3.tar...

How to Secure a cPanel/WHM Web Server

Here are a few basic steps that you should keep in mind for keeping a server secure. 1) Strong...